Reports aren't working

Aug 29, 2012 at 1:20 PM

Hi,

I've installed the Kanban template few weeks back, and everything is great except the reports.

The main report we are interested in is the Kanban board, but cannot get it to find allow choice of the Area and Iteration path parameters.

We are using TFS2010, reporting server is on the same machine with the App Tier.

I've created a new project to test the Kanban after I imported the template to the collection.

I've tried to examine the Kanban Board RDL to the best of my abilities (have little knowledge of reporting), and also got assistance, and in the end found the below.

After connecting the RDL to our server, as it kept looking for the ALM Rangers server, when checking the DataSet query it keeps saing it canot find fields (DIM...Kanban_ProcessStep). I've checked in the DIM table (I was explained this is the data warehouse for the reporting) and couldn't find the field in the table. It seems no *.Kanban.* field exists in that table at all, and I'm guessing this explains the reason the Kanban reports are not working.

I'm trying to understand what direction to go in order to solve this, and also what might have gone wrong in the template import process (no errors given). 

Would highly appreciate our help.

Thanks,

Shai Gilboa

Developer
Aug 29, 2012 at 4:42 PM

Hi Shai,

Can I confirm whether you have deployed the latest version of the template published

  Tue Aug 14 2012 at 8:00 AM

Thanks,

adam

 

Aug 29, 2012 at 6:09 PM

I installed at the end of July which means it was the last 'beta' version.

I downloaded the Aug 14 release and according to my checking only the documentation changed (binary compare of folders + date/time compare).

Feb 12, 2013 at 1:37 PM
Edited Feb 12, 2013 at 1:38 PM
I too am running accross this problem. It seems that the filters for the Kanban Board report are not being correctly populated, and on the other reports, it is complaining about missing Dim tables. I too know next to nothing about SSRS, so any help would be great
Feb 15, 2013 at 10:17 AM
I am not an expert in this area. I have had the suggestion that you try reprocessing the TFS cube manually in SQL Server Management Studio. Have you tried this?

Regards

Rob